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Overview 
 
The acslX Excel Simulation Interface is an add-in utility for Microsoft Excel which allows 
simulations created in acslXtreme to be controlled and analyzed using Microsoft Excel.  
This utility works by associating cells in an Excel workbook to specific model variables.  
In particular, cells associated with model constants can be used to specify the values of 
those constants prior to a simulation run; model outputs of interest may similarly be 
collected and inserted into specific cells at the conclusion of the run.  Since the model 
inputs and outputs are simple Excel cells, the complete mathematical, plotting and data 
import/export facilities available from Excel may be used in the analysis of acslX 
simulation data. 
 

Installation 
 
To install the add-in, simply run the Setup.exe program (or, alternatively, the 
AxExcelAddinSetup.msi file) and follow the instructions provided in the installation 
wizard.  In general, it is best to use an administrative account to install the add-in; when 
asked whether the utility should be available to everyone using the computer, make sure 
to select the “Everyone” radio button in the installation wizard if other users on the 
computer will need to run the program. 
 
After completing the installation, you should have a new start menu item in the AEgis 
Technologies folder entitled “acslX Excel Simulation Interface.”  In addition, a new 
toolbar should be present when you start Microsoft Excel. 
 
This add-in requires Microsoft .Net framework 1.1 or later to be installed.  If a valid 
version of the Framework is not found by the installer, you will be given an opportunity to 
download and install it. 
 
Removal of the add-in can be accomplished using the “Add or Remove Programs” 
applet in the Windows Control Panel.  Just double-click the “acslX Excel Simulation 
Interface” entry in the installed programs list to remove the program. 



 
Use of this add-in requires a license key file which is available from your AEgis sales 
representative.  If you already have acslXtreme installed, this key file can be placed in 
the same folder as your acslXtreme license file (typically in the acslXtreme installation 
folder).  If you do not have acslXtreme installed, place this file in the folder in which the 
add-in was installed (the default location is “C:\Program Files\AEgis Technologies\acslX 
Excel Simulation Interface”).  You will then need to create an environment variable 
named LM_LICENSE_FILE which points to this folder.  To do this, open the System 
Settings applet under Windows by selecting the Start Menu -> Control Panel -> System 
icon.  When this dialog opens, select the “Advanced” tab and press the “Environment 
Variables” button.  You should see a dialog similar to the following: 
 
 

 
 
 
Under the “System Variables” list, select the “New” button and create a new environment 
variable pointing to the acslX add-in installation folder: 
 



 
 

 
Once the license key is in place, the add-in should be ready for use. 
 

 

Basic Operation 
 
Use of the simulation interface add-in requires a few fundamental operations which are 
accomplished using the “acslX” toolbar loaded by the add-in when Excel starts. 
 

 
 

The function of the four toolbar buttons is summarized here; detailed instructions are 
presented in the sections below. 
 

 

Specify simulation DLL.  Displays a file dialog from 
which the acslX simulation DLL to be associated with the 
current workbook is specified. 

 

Specify simulation inputs/outputs.  Displays a dialog box 
from which the model variables may be associated with 
cells in the spreadsheet. 

 
Reset simulation.  Reloads the current simulation DLL so 
that all data is re-initialized to default values. 

 

Start simulation.  Stores the values of selected constants 
from spreadsheet cells into the simulation, runs the 
simulation, then displays selected outputs in 
corresponding cells. 

 
The fundamental work flow for using acslX simulations from within Excel consists of six 
basic steps: 
 

1. Create a new workbook with the necessary sheets for interfacing with acslX. 
2. Specify the acslX simulation DLL which with which the workbook will 

communicate. 
3. Specify what model variables will be associated with spreadsheet cells (inputs 

and outputs). 
4. Set any desired input values via the spreadsheet. 
5. Run the simulation. 



6. Analyze the output values. 
 
These steps are described in detail in the following sections. 
 

Creating a New Workbook 
 
Operation of the acslX add-in requires that the associated workbook has specific sheets 
present, as the add-in logic depends on the existence of certain sheets to know where to 
retrieve and store information related to settings and input/output values.  As a result, 
new workbooks are most easily created using a provided template, which is located in 
the installation folder specified when the add-in was originally installed.  This can be 
done using the “acslX Excel Simulation Interface” shortcut installed in the start menu; 
this link will open a new Excel document based on this template. 
 

 
 
 
Alternatively, a new acslX-enabled workbook may be created using the File -> New… 
option from the Excel main menu.  A panel will be displayed with a number of options for 
creating a new workbook; select the option to create a new workbook based on a 
template on your computer (Templates -> On my computer…). 
 

 
 
 
This will display another dialog containing a list of available templates: 
 



 
 
 
Select the “acslX simulation.xlt” template.  You should then see a workbook which looks 
like the following: 
 
 

 
 
 
 



Description of an acslX-enabled Workbook 

 
The “Summary” sheet contains cells which are associated with selected input and output 
model variables.  This page is used to set the values of constants prior to a simulation 
run, and collect the final values of model outputs following a run.  “Initial value” columns 
report the values of those variable when the simulation is loaded – i.e., the default 
values specified in the DLL.  The “current value” column is used to either specify or 
report the value of the constant or variable before or after the simulation run. 
 
The “Time Histories” page is used to optionally collect the values of output variables at 
each communication interval during a simulation run; this is useful when plotting the time 
dependence of a model output over the course of a run. 
 
Note that the sheets present when the workbook is created must be present for 
operation of the add-in.  Removing or renaming these sheets will break the simulation 
interface for that workbook.  Addition of other sheets into the workbook is perfectly 
acceptable. 
 

Specifying the acslX Simulation to Use 
 
In order to associate the new workbook with a particular simulation DLL, select the “Load 
acslX Simulation” toolbar button.  A file open dialog will be shown from which you should 
specify the location of a valid acslXtreme simulation DLL. 
 

 



 

Specifying Inputs and Outputs 
Once the workbook has been associated with a valid acslXtreme simulation DLL, cells in 
the “Summary” sheet can be associated with model inputs and outputs. 
 

 
 

The presented list of constants/variables is determined from the simulation DLL selected 
earlier.  Check the boxes next to any desired constants (inputs) or variables (outputs) to 
be associated with cells in the “Summary” page.  If time histories should be collected for 
any of the output variables, also check the “Collect Time Histories” box under the list of 
outputs.  Note that collecting time history information will introduce a certain amount of 
communications overhead which will increase the amount of time necessary for each 
simulation run. 
 
Once the desired inputs and outputs have been selected, press the “OK” button to return 
to the spreadsheet.  Cells should now be populated on the “Summary” page as shown 
below. 

 



 
 

Setting Input Values 
To set the values of one or more constants (inputs) prior to a run, simply enter the 
desired value in the corresponding cell under the “Current Value” column.  This value will 
be copied into the simulation prior to the simulation run.  The contents of this cell need 
not be a literal numeric value – it many cases this will contain either a formula or 
reference to another cell.  It may also be the case that the value in this cell is determined 
by another Excel add-in, or by a macro. 
 

Running the Simulation 
 
Once input values have been specified, the simulation is executed using the “Run acslX 
simulation” toolbar button.  At conclusion of the run, the “Current Value” cells for any 
selected outputs will reflect the values of those variables at the end of the run.  If time 
histories are collected, these cells will update during the course of the run, and a column 
containing the values of the variable at each communication interval will be presented on 
the “Time Histories” sheet.  Either of these cell ranges may be used as inputs to other 
computations specified elsewhere in the workbook. 
 
In some cases, it may be required to have the simulation run started programmatically, 
as opposed to manually via the toolbar button.  Refer to the “Advanced Control” section 
below for instructions on how to do this. 
 
The “Reset simulation” toolbar button is provided in order to restore all simulation 
variables to their default values as encoded in the simulation DLL.  This is done by 
unloading and reloading the simulation. 
 

Analyzing the Outputs 
 
Analyses on simulation outputs are performed by simply using the output cells on the 
“Summary” and “Time Histories” spreadsheets as inputs to calculations just as you 
would any other Excel cells.  For example, a plot of the time histories of the outputs can 



be created by selecting the columns of data on the time history sheets and using the 
Excel Main Menu -> Insert -> Chart wizard.  See the image below for an example. 
 

 
 
 

Advanced Control via Visual Basic for Applications 
 
In some applications, it may be necessary to programmatically invoke the start of the 
simulation run (i.e., as opposed to using the “start simulation” toolbar button).  In these 
situations, the toolbar button can effectively be invoked via VBA code as in the following 
example: 
 
 

Sub StartSimulation() 

Application.CommandBars("acslx").Controls("Run acslX simulation").Execute 

End Sub 

 

 
This ability is particularly useful when used in coordination with other add-ins (e.g., 
Monte-Carlo analysis tools such as @Risk and Crystal Ball), in which case the acslX 
simulation will be run hundreds or thousands of times under the control of another 
application. 
 
The specific procedure for adding the cod to invoke the start of the simulation run will 
depend on the application which is used to control the execution.  In general, however, 
most techniques will require the creation of a VBA subroutine like that shown above 
using the Excel Visual Basic Editor (Main Menu -> Tools -> Macro -> Visual Basic 



Editor).  For specifics regarding how to add the subroutine, refer to the Excel Visual 
Basic for Applications documentation, and any other application third-party product 
documentation. 
 

Known Limitations 
 

1. Only scalar (i.e., non-array) variables may be associated with cells in the 
spreadsheet. 

2. Non-numeric (i.e., string) data types are not currently supported. 
 
The following issues have been addressed as of the current release: 
 

1. Multiple acslX worksheets may now be open at one time within Excel. 
2. Formulas for model inputs (constants) entered in the “Current Values” column on 

the Summary sheet are now preserved when changing the list of selected 
inputs/outputs. 

3. Logic related to the way in which the name/location of the acslX simulation DLL 
associated with the worksheet is persisted has been improved; the add-in now 
additionally looks for the DLL in the same folder as the .XLS file, making transfer 
of worksheets between users on different computers easier. 

4. A number of issues were fixed which prevented the add-in from working with 
older versions of Excel (e.g., Excel 2000). 

Support 
 
For installation or technical support, please contact AEgis support via email at 
support@aegistg.com. 
 
 
 


